php spot
phpが使えるレンタルサーバー特集
検索グラス
トップページへ

UNIX環境へのPHP4インストール
PHP4のサポートは既に終了しています。特に理由がない場合はPHP5をインストールしましょう
PHP5のインストール

UNIX環境へのPHP4インストール方法を紹介します。#ではじまる行はUNIXでのコマンドを示します

configureプログラムの実行
# tar xzvf php-4.x.x.tar.gz
# cd php-4.x.x
# ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring --enable-mbsrt-enc-trans --enable-mbregex --enable-trans-sid --with-mysql=/usr/local/mysql --with-zlib-dir=/usr/local/lib --with-png-dir=/usr/local/lib --with-jpeg-dir=/usr/local/lib --with-freetype-dir=/usr/local/lib --with-gd=/usr/local/ --enable-gd-native-ttf

ライブラリのインストールに失敗し、インストールできない場合、インストールできなかったライブラリの追加オプションを外すことでインストールできる場合があります。
例)libpngの場合→--enable-png-dirの表記を削除

PHPのコンパイルとインストール実行
# make
# make install

/usr/local/apache2/conf/httpd.conf のAddType部分を追加

AddType application/x-httpd-php .php

PHPの動作確認
インストール解説ページに戻る

スポンサードリンク


管理人の新着ブログ記事

    プライバシーポリシー | お問い合わせ
copyright © 2003-2021 phpspot all rights reserved. powered by phpspot CMS.